ERROR Python
2019.07.03

【解決方法】django.core.exceptions.ImproperlyConfigured: SQLite 3.8.3 or later is required (found 3.7.17).

SQLite3.8.3より下のバージョンになっているからバージョンアップしてねというエラーです。 このエラーに丸5日間はまりました。
仕事そっちのけでdjangoのデプロイに時間を割いたのでおかげで仕事が溜まりにたまってしまいました...

環境

さくらVPS centos7 django 2.2 python3.6

結論

django2.2以上のバージョンでこのエラーが私の場合発生しました。なので、django2.1にバージョンダウンしたらOK! 仮想環境がない人はこちらを参考にしてください。 venv: Python 仮想環境管理 pythonの仮想環境を作成している場合は、 source [仮想環境]/bin/activate その後 してください。 service httpd reload してアクセスして完了。 ちなみに 私の場合confの設定では、 /etc/httpd/conf/httpd-le-ssl.conf 私の場合、マルチドメインでssl設定を先にしましたので次のようになります。 /etc/httpd/conf/httpd.conf(もしくdjango.confのような新規ファイルを作成)にVirtualHost *:80で記述しましょう。 設定方法は、「django vortialhost設定」と調べたら参考サイトはございますので確認してください。 django2.2でSQLite3.8.3以上のバージョンをダウンロードしてやったりしましたが私の場合うまくいきませんでした。 参考サイト Django2.2で開発サーバー起動時にSQLite3のエラーが出た場合の対応